Wikia

Dragon Age Wiki

Talk:The Battle of Denerim

7,336pages on
this wiki

Back to page

Morrigan's OfferEdit

Does anyone know if Morrigan has to be in the party when you slay the archdemon to accept her offer?

Lord K (talk) 19:41, August 27, 2010 (UTC)

You are not forced to take her with you (like Wynne in the tower). AFAIR there was no special cut-scene with Morrigan. So I think the answer is no. --Ladguru (talk) 08:29, August 28, 2010 (UTC)

Sacrifice DecisionEdit

I find the section about the decision about who kills the archdemon rather unclear. In my playthrough, Alistair wanted to sacrifice himself without a romance with my character. I had romanced Leiliana and also rejected his offered rose. Could it be that the decision if he wants to sacrifice himself depends on approval rather than romance?

Tifereth 20:40, May 17, 2010 (UTC)

His approval is more like an honor task to do. When I romance him and I don't want Morrigan to make the ritual, I always remove him from my party when I'm going to kill the Archdemon. If you romance him and have him on your party, doesn't matter what you say, what you do, he'll always make the ultimate sacrifice.
If you are only friends with him, he'll let you do the sacrifice if you persuade him.
I guess that even if he does not like you, he'll let you do the sacrifice or you'll let him do the sacrifice. Depends on which options you choose. Rocketai (talk) 07:52, June 19, 2010 (UTC)

Just some suggestions for what should be included here.Edit

Entering the gates of Denerim -Enemies encountered -Selecting Party members to continue into the city.

Army Tactics Benefits of each ally and how to most effectively use them and in which of the following areas -Dwarfs -Golems -Redcliff Infantry -Elves -Werewolves -Mages -Templars

The Market -Description of the environment -Enemies and Tactics

Alienage -roughly same as above -choices regarding getting the elves to help

City Gates -

Palace -

Fort Drakan -Link to Archdemon Page

Ways to achieve each of the (4?) different endings.



In the palace district, I encountered Dagon Thralls, which are not mentioned. I think these possibly take the place of the ogres which are listed in the same area. can anyone else confirm? Yes i have dragon thralls 2, but i also have ogres.... NOT fun 75.90.145.36 21:24, February 7, 2010 (UTC)


What happens in the final cut scenes of each different ending. Possibly a whole page devoted to the endings based on your choices throughout the game.


Any further suggestions?

--Wraith78 18:53, December 9, 2009 (UTC)

maps would be nice too - i've not worked out how to capture them to UL yet.

I thought the name of this quest was the Final Onslaught. Is that wrong? I've just never seen the battle of Denerim listed as a quest. Unless I just didn't look which is entirely possible! After Redcliffe though I usually only have one quest left in my queue and that is The Final Onslaught. --MiyuEmi 14:36, December 16, 2009 (UTC)

The quest is called The Final Onslaught yes, but the event that takes place is more fitting to be called the Battle of Denerim - for the simple fact that it is a battle between the Darkspawn and the United Armies of Ferelden, in my opinion anyway. Zf6hellion 15:43, December 16, 2009 (UTC)

Isn't it about time to remove the "stub" tag? Cheesy123456789 16:15, December 19, 2009 (UTC)

BugEdit

After killing the horde in the alienage my party became stuck when the arch demon destroyed the bridge in front of us. I think there may be a positioning bug if the majority of the party is on the 'wrong' side of the bridge when the cut sceen is triggered.Tetracycloide 21:06, December 22, 2009 (UTC)

Which version of the game did this happen on? Zf6hellion 11:15, December 23, 2009 (UTC)

PC version patch 1.1 i think. if not version 1.2 Tetracycloide 18:12, December 28, 2009 (UTC)

Well so far on the PS3 I've been unable to incur that bug so I can't really find a solution unfortunately. Zf6hellion 23:00, December 28, 2009 (UTC)

On the PC when standing on one end of the bridge you can use the mouse and cursor to activate the gate on the far side. After doing so if you switch to control another character the party will stop with the exception of the character that was just used to open the gate. I'm not sure how, exactly, the controls work on the console versions but I suspect this isn't possible without a cursor.Tetracycloide 15:49, December 29, 2009 (UTC)

I have encountered this same bug on the fully patched PC version using the method described above. /Keivz

In the city gates I thinks there's a bug since whenever I talk to Riorden so he can tell me the tactics all he says is "Press forward!" what should I do?

                (Witch Maker)

Party and the Archdemon Edit

Does the warden have a fixed party for this battle? If not, say if the player chose Zevran and Sten and Shale with them in the final battle againts the Archdemon, and sten makes the final blow. Is that possible, or do you fight the dragon alone?

You get to choose the party you take with you, but it must always be a Grey Warden that "strikes the final blow", so if you're the only Grey Warden in the party it will be you. This is a story thing and is irrespective of who actually strikes the blow that reduces the Archdemon's health to zero. Zoev 02:49, January 11, 2010 (UTC)

Main floor and second floor of the fort Edit

The walkthrough here says the second floor is smaller than the first floor. I find that the second floor is MUCH larger than the first. There is one door I cant open yet that according to the map just leads to a room. Am I missing something?



Srsuth

dragon thralls Edit

yeah the thralls r in my game 2 but, with ogres 2

Clean up/Revise?

I think this page needs to be cleaned up some. There seems to be a good deal of information missing about this final battle that would be helpful for people to know, such as the quest "Defend the Alienage" where you find the second Darkspawn General (Hurlock Emissary) and recieve the Dawn Ring as a reward and "Hold the Gates" where the companions you leave behind have to fight back waves of Darkspawn. This caught me by suprise and if people by chance didn't have the extra members that weren't in the party equiped it might cause some issues. I didn't want to just go through and change things around though and thought it would be best to ask about it here first. Bandit-Behind-Bars 07:29, February 17, 2010 (UTC)


Bug at Redcliffe CastleEdit

Oddest thing...I was in the initial conversation at Redcliffe Castle. I spared Loghain and of course, Alistair left--but I got Alistair's dialogue in his voice, with the camera on Loghain every time. Is this a known issue? Rosenoire 10:06, April 20, 2010 (UTC)

Crazy LagEdit

I get crazy lag during this quest and the preceding fighting in Redcliffe. All the white badguys die in a single shot/hit, but I will shoot them, they will show no damage for 1-2 seconds, then they'll fall over dead. Does anyone else get crazy lag during these battles? Servius 01:48, May 7, 2010 (UTC)

Yep. Especially at the city gate. White guys running around with 3 or more arrows in the chest and my pals chasing them... --Ladguru (talk) 09:17, August 17, 2010 (UTC)


I've gotten lag from having Morrigan killing enemies while in Sleep, but also from the soldiers who die when Bann Teagan attacks. --Rival grace 10:09, May 7, 2010 (UTC)


I logged out of the EA/BioWare network thing and I think that made a pretty big difference. Too bad it also made my Warden's Keep items disappear. Is there a hack that enables access to those items even if you're not logged in? Servius 18:32, May 7, 2010 (UTC)

Got 5-10 seconds lag for health poultices and usually instant kill attacks. Pretty game-breaking at that point in the game. Logging out doesn't help. -- 91.62.252.83 (talk) 22:04, June 12, 2011 (UTC)

Defend the Alienage Edit

I just played through this section and I was not able to get the elves to fight with me - they ran away. There was no 'persuasion' option. I am playing as an elf, so the comment in the text: "If you are a City Elf, she will always help without need for persuasion, insisting even if told to run away." is not accurate. I don't know what exactly needs to happen to convince the elves to fight. My first playthrough was with a human noble warden and I managed to persuade them to fight, but this time (elf mage) I didn't even have the option to do so. PurpleRayne 20:09, May 10, 2010 (UTC)

How did you resolve the Alienage quest in your elf playthrough? Was it different from how you resolved it during your human noble playthrough? Servius 18:20, May 11, 2010 (UTC)
In the first playthrough of Unrest in the Alienage I entered the hospice by bribing the guard at the back door. In the second playthrough (as an elf) I aggravated the healers and guards out front, thus ending up killing a few bystanders that joined the fight. Maybe that's the key? PurpleRayne 20:58, May 11, 2010 (UTC)
May have been. I was thinking that Shianni is the person you interact with during the final battle in the Alienage, who was also involved in the earlier quest. If you couldn't persuade her to help fight the Darkspawn, it may be because she didn't trust you, which may have been due to prior actions like causing civilian casualties during the earlier quest. Just a guess, but there's some logic there. Servius 23:29, May 11, 2010 (UTC)
Note that the article doesn't say that the elves will automatically help you "if you are an elf." It says, "if you are a City Elf," as in the City Elf origin. That's because Shianni is the City Elf's cousin. Shianni insisted on staying to help my City Elf because "this is our home, too," but presumably the fact that he was family also has something to do with it.--DarkAger 00:05, May 12, 2010 (UTC)
From my experience with a city elf origin character (I was the one who made the edit), the statement is accurate. Shianni and the other elves insisted on fighting regardless of what dialog option was taken. Elves of magi or Dalish background will presumably need to persuade her since you are not cousins. As to why you didn't even have the option to do so, I'm not really sure. As suggested, offending the elves by getting the bystanders killed might have caused them to not trust you. I have never had the heart to do something bad during that quest so I really can't say. Dr. Abysmal 01:11, May 12, 2010 (UTC)
I'm not sure what you mean by 'City Elf'. According to the mage-elf's backstory, he was taken from an Alienage at an early ago to go study at the Circle of Magi; woudn't that mean 'City Elf' as well? As far as I've seen in this game there are only two kinds of elves: Alienage/city/lower-class pseudo-slaves and the Dalish. Regardless, I dont have enough data one way or another to dispute your assertion. PurpleRayne 13:32, May 12, 2010 (UTC)
Sorry - I should have researched before posting: I now see what you mean by 'City Elf' - it's one of the 6 Origins. Carry on. :-) PurpleRayne 13:37, May 12, 2010 (UTC)

Bug in the ending Edit

After killing the archdemon, Alistair isn't in the landsmeet hall, even if he's actually still alive. I didn't make him marry Anora and I accepted Morrigan's offer, but I haven't chosen him for fighting the archdemon: I used Leliana, Sten and Morrigan, but I even played with Alistair in the palace district, so he sould be alive. No character mentioned his death after the battle. Is this a bug of the game or it depends on having not chosen him? According to the page he shouldn't be required... 87.15.29.200 (talk) 01:40, June 19, 2010 (UTC)

Hi! I did exactly the same thing and didn't experience the bug. It may have other conditions as well. July 8, 2010

did you become the king with anora? because alistair doesn't show up according to certain conditions. Check the Epilogue (Origins) page for the reason why. User:Eggy2504, 11:28, 3 June, 2011

Alienage Bug Edit

Here's some technical info on the Alienage bug. Well, bugs, actually, plural. First, the journal entry. The game simply assumes that you failed to kill the general at the market and changes the journal entry to "failed" once you exit the alienage.

Second bug: The market district does not become unavailable after the bridge is destroyed, you can still travel from the alienage (or the palace district) back to the market district. Doesn't make sense. Should be set to greyed out together with the alienage location as soon as the bridge in the Alienage is destroyed.

All bugs are in the cli600ar_elven_alienage.nss script.

Here's the proper code:

case EVENT_TYPE_AREALOAD_PRELOADEXIT:

{

... //original code

object oMarket = GetObjectByTag("wml_cli_market");

object oAlienage = GetObjectByTag("wml_cli_elven_alienage");

object oPalace = GetObjectByTag("wml_cli_palace_district");

WR_SetWorldMapLocationStatus(oMarket, WM_LOCATION_GRAYED_OUT);

WR_SetWorldMapLocationStatus(oAlienage, WM_LOCATION_GRAYED_OUT);

WR_SetWorldMapLocationStatus(oPalace, WM_LOCATION_ACTIVE);

...

case EVENT_TYPE_EXIT:

{

object oCreature = GetEventCreator(ev);

if(GetPartyLeader() == oCreature)

{

if(WR_GetPlotFlag(PLT_CLIPT_GENERAL_MARKET, CLIPT_GENERAL_MARKET_KILLED) != TRUE)

{

object oMarket = GetObjectByTag("wml_cli_market");

WR_SetWorldMapLocationStatus(oMarket, WM_LOCATION_DESTROYED);


WR_SetPlotFlag(PLT_CLIPT_GENERAL_MARKET, CLIPT_GENERAL_MARKET_LOST, TRUE);

}

} ... WRFan (talk) 22:46, July 15, 2010 (UTC)

Cutscene bug?Edit

This is one case that doesn't seem documented. On my playthrough I convinced a hardened Alistair to marry Anora, spared Loghain, did not do the ritual with Morrigan and had him (Loghain) take the final blow yet the ending cutscene only shows and mentions Anora as the queen. Is this normal or is it a bug?

What do you mean by that? You mean, it only shows Anora as a queen in the epilogue or when there's the part of being blessed by the revered mother, only Anora appears instead of Alistair and Anora? If it's in the epilogue, I wouldn't worry much about that... The epilogue is full of rubbish sometimes, for example: if you marry Alistair, in the epilogue it shows you as a Princess-Consort instead of queen. --Rocketai (talk) 20:13, July 16, 2010 (UTC)

Possible Bug?? Edit

First time playing on the xbox, I got to The Final Battle. the beginning of the Final Battle, you fight off the small waves of grunts, but after I killed all of them, nothing happened. I am positive that all the darkspawn in that part are killed, but every time I engage Riordan, all he yells is "Press Foreward!" then nothing. I've initiated conversations with other characters, and still nothing. Just wondering, has anyone else come across this problem, and if so, what did you do to get out of it?


I have same at PC, latest version. 85.141.74.226 (talk) 01:28, August 13, 2011 (UTC)

Fort Drakon Main Floor Bug Edit

Was wondering if anyone with the PC version had this. During the fight with the Genlock Conjurer, I tried casting Mana Clash on the Genlock Conjurer himself, the game then crashed. I've tried this about ten times with the same result every time.--173.175.11.110 (talk) 03:54, October 27, 2010 (UTC)

Major Redcliffe Bug Edit

I'm in Redcliffe, trying this quest for the third time. The first two times, I killed all the Darkspawn and could NOT find any officer to talk to. This third time, the game froze while I was killing an Ogre. Anybody know why this might be? For reference, I'm a Human Noble Rogue, DW, engaged to Anora and using Loghain as a tank. I had Alistair killed. Partsthewaves (talk) 18:36, October 27, 2010 (UTC)

It's possible the officer was killed by the Darkspawn. --JimmyTheCannon (talk) 22:06, January 26, 2012 (UTC)

Can you reload for multiple achievements? Edit

Can you play through the final battle and sacrifice yourself first, then reload before the battle and have one of the other characters, specifically Loghain sacrifice himself and earn both achievements? Or will you need to play through the game twice to get those? This question is also relevant to earning the achievements about killing 50 enemies with a specific skill. Can you kill everything in an area, then reload before an area and the numbers count towards 50 together?

How many Dragon Thralls at the entrance? Edit

I remember only one, as stated in the article, until I played on Nightmare, where there were TWO of them... -- Marvin Arnold (talk)

I did that battle twice on Normal and there were 2 of them. Pudim17 (talk - contr) 18:50, June 8, 2011 (UTC)

I did that battle several times on diffrent difficulty levels. Most of the time it appears to be one unless you kill it to quickly/ or maybe before it could that annoying roar ability? 12:10 16th July/2011 AK

Does anyone else have this issue? Edit

I'm playing the 360 version and I'm trying to get through the palace district, but I just noticed that there are squads of mages dwarves or any of the others...the wheel is just blank. The only squads I have used so far are humans and dwarves. Shouldn't I still have elves and mages available to me? I'm having ALOT of trouble getting through without them. Thanks!! DeloreanFanatic (talk) 00:33, March 3, 2011 (UTC)

Are the darkspawn supposed to be incredibly easy? Edit

  • PLEASE NO SPOILERS!* Just getting to this page I've seen more than I would like to in terms of story elements I haven't seen yet.

I just got to Redcliffe for the final battle and the darkspawn in the village are dying way too easily. Just about every enemy short of Alphas are falling after one normal attack from my rogue or by wandering into Morrigan's tempest attack. So is this a bug or am I supposed to be satisfied that my party is brushing everything aside without any semblance of a challenge? --El expl0siv0 23:58, April 27, 2011 (UTC)

That'S normal behavior at that point. You leveled up, the darkspawn grunts didn't. -- 91.62.252.83 (talk) 22:07, June 12, 2011 (UTC)


I have that problem to I am playing on Nightmare and let my troops do almost all the work with no losses. Its just no fun are you supposed not to use troops or what? Are there any mods for this? 18:00 25.May 2011

No Eamon etc. Edit

On this page it states that Arl Eamon and either (swiftrunner, zathrian), (gregoir, irving) and kardol are supposed to show up fro the final fight against the archdemon. I was playing through it and got to the archdemon to find that i was alone, with only my party. I could still call up armies, but these heroes werent there. Is this a common bug (on xbox) User:Eggy2504, 11:26, 3 June, 2011

Vanishing Equipment Bug Edit

I've hit this a couple of times since starting The Battle of Denerim. Basically every so often after a fight I find that 2/3 of my equipment simply vanishes (91/120 down to 25/120). If I reload the previous save, fight again the equipment is still there.

--Tarasis (talk) 14:58, July 14, 2011 (UTC)

With patch 1.04, just got this bug transitioning from the Palace District to Fort Drakon. Also took almost all the money, have 5 sovereigns left. 75.179.145.176 (talk) 22:34, September 26, 2011 (UTC)

Defender Achievement Edit

I got the Defender Achievement once I entered Fort Drakon's Main Floor, not after defeating the Archdemon. --JimmyTheCannon (talk) 23:58, January 26, 2012 (UTC)

Got both achievements? Edit

I just killed the archdemon today, and chose the ritual option. I got the achievement for it. Then I loaded my save, and suddenly got the achievement for sacrificing myself. I didn't even start a second playthrough, I just loaded the post-epilogue save and got the achievement. Has anyone else encountered this? I'm on a PS3, if that helps. Edendhri (talk) 21:02, July 25, 2012 (UTC)

Strange. I can't think of any other reason from being a bug. Viktoria Landers 06:44, July 26, 2012 (UTC)

Alistair sacrifice/romance Edit

Note: If you are romantically involved with Alistair, and he is with you at the final battle, he will take the final stroke to slay the Archdemon,unless you chose the "I can't let you do that" option.

^Can someone verify this? I recently tried going against the Archdemon while in a relationship with Alistair, all dialogue options end with him committing the ultimate sacrifice (including the "I can't let you do that" option.) 76.93.146.70 (talk) 08:12, November 14, 2012 (UTC)

^^I think they used a mod. I can't find any videos that says how they sacrificed the warden with a romanced Alistair except videos with a mod in the title. (Lady In Raven)
^^Yeeeaaaahhhhh..... I found 1 vid in youtube that shows how to sacrifice the warden with a romanced Alistair but there was an option that didn't appear with my dialog. Tell me if you tried using this option and this special op didn't appear then we can be sure it they used a mod. Try choosing "This is my duty as a Warden as well as yours. We're both Gray Wardens", "I think you would be a good king." then there is this option "[name of char. (I think)] No, Wait! Last kiss? I want to remember....(Knock him out)" Pls pm me about this. I'm also trying to get this ending with my warden. Lady In Raven ||^_\\\

To the one who noted about Alistair's not sacrificing himself..... Did you used a mod? Edit

There was a note on this that Alistair won't sacrifice himself if you chose "I can't let you do that." Could the one who wrote that elaborate the options you took so I could have the same ending, because I'm preeeettttyyyyy sure that a mod was used there. I'm just renting the ps3 and its FREAKING expensive even if you're just playing for 2 hours. If so, I am begging you or anyone STOP PUTTING MOD POSSIBILITIES IN HERE. IT'S FREAKING ANNOYING! And can somebody erase that if no one can prove that this wasn't a result of a mod. Lady In Raven ||>_<\\\

Article Name Edit

This quest in-game is called "The Final Onslaught" (with the subquest name "The Final Battle")--shouldn't that be the name of this article instead? Part of the quest is in Redcliffe, after all, so it doesn't make sense to call it The Battle of Denerim. In fact, "Final Onslaught" doesn't appear anywhere on the wiki at all. --Kelcat (talk) 04:53, March 27, 2014 (UTC)

Around Wikia's network

Random Wiki