Wikia

Dragon Age Wiki

Black Grimoire bug?

7,243pages on
this wiki

Forum page

Forums: Index > Game Discussion > Black Grimoire bug?
Note: This topic has been unedited for 982 days. It is considered archived - the discussion is over. Do not continue it unless it really needs a response.

Possible bug with Flemeth`s Grimoire quest? I picked the lock earlier in the game and got the Black Grimoire, and i gave it to Morrigan long before the Flemeth`s Grimoire quest was opened. Now i have an active quest for Flemeths Grimoire. The details state that Morrigan believes in to be located inside the magi`s tower, but it isnt there because i already gave it to her, and it seems that the quest is now stalled. Morrigns approval is at 100. Romance has been initiated and consumated. I have gone to Flemmeth`s hut without Morrigan and i did not encounter Flemeth. Have i missed something? Has this happened to anyone else? Help would be appreciated. Thank you. 99.195.47.116 (talk) 21:47, October 2, 2010 (UTC) turbodog

when you are in flemeth's hut the first time (after the tower of ishal), the chest with her real gimoire is not able to be picked (or should not be able to be, so if you did it is a bug). the first grimoire you should find is in the mage tower, i think in first enchanter's office. after you give that one to morrigan, she will ask you to get the "real" grimoire from flemeth by killing her. Kurli (talk) 23:43, October 2, 2010 (UTC)

Hi Kurli. Morrigan never asked me to go to Flemeths yet. Thats the problem, she asked me to get the book from the the magis circle, but i already gave it to her. I gave it to her earlier in the game, as a gift, before the quest was open. So now that the quest is availible, i cant give it to her to advance the quest......... not sure what to do. 99.195.47.116 (talk) 04:14, October 3, 2010 (UTC)turbodog

Are you sure you're not confusing her fake and real Grimoires? The one from the circle you give to her and she studies it. Later, you talk to her and she tells you that she needs Flemeth's true Grimoire. That's when she tells you to go to the hut without her, and to kill Flemeth. LVTDUDE (talk) 04:23, October 3, 2010 (UTC)

Um, isn't that chest in Flemeth's hut a "key chest"? You know, the ones that should be impossible to get into without a key? Honestly, I think the real glitch is the fact that you were able to pick that lock in the first place, because every time I've clicked on it on MY game without getting Flemeth's key, it says "key required." Hitokiri Akins (talk) 05:00, October 3, 2010 (UTC)

i`m sorry, i think maybe i didnt explain properly. I picked the lock on the chest in the magi tower to get the fake grimoire. I gave it to morrigan as a gift earlier in the game before the quest opened. Later, she spoke to me about the grimoire and asked me to get it from the magi`s tower. Since i already got it, and gave it to her, i cant give it to her again to advance the quest, so she has never told me it was fake and asked me to get the real one. I think i just gave her the fake one too soon. I shouldnt have given it to her until the quest was open and she asked for it. Now, i cant advance the quest and dont knwo what to do. 99.195.9.146 (talk) 18:28, October 4, 2010 (UTC) turbodog
Go back to camp; she'll talk about what's in the grimoire with you. Hitokiri Akins (talk) 18:35, October 4, 2010 (UTC)


New user: I have the same issue-- "I picked the lock on the chest at the tower, and gave her the grimoire as a gift while we were in the tower. Once I returned to camp she spoke to me about the grimoire and asked me to get it from the magi`s tower. Since i already had given it to her- i cant give it to her again to advance the quest. I have tried talking to her many many times back, after each new major advance (i.e after we level say 3 or 4 times) at camp with still no luck - Any ideas or is this quest to always be open and never completed? (Novemeber 17 2011)--101.114.141.188 (talk) 04:56, November 18, 2011 (UTC)

If you're playing on PC, use this mod [1] and get another copy of the item. If you're on console, I'm not sure what you can do. Whocares65 (talk) 19:24, November 18, 2011 (UTC)

Around Wikia's network

Random Wiki